Degraded responsiveness and 502 Gateway timeouts
Incident Report for Crunch.io
Resolved
As implemented, a bug fix in our last software release had an unexpected negative impact on the performance of all API endpoints. As a result, API response times increased, and sometimes timed out. This was most noticeable in specific large datasets. We have rolled back the relevant code change, and API response times are back to normal levels.
Posted Feb 13, 2020 - 03:25 PST
Update
We are continuing to monitor for any further issues.
Posted Feb 12, 2020 - 11:58 PST
Update
We are continuing to monitor for any further issues.
Posted Feb 12, 2020 - 11:51 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 12, 2020 - 11:51 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 12, 2020 - 11:20 PST
Investigating
We are currently investigating this issue.
Posted Feb 12, 2020 - 10:31 PST
This incident affected: Crunch.io Web Application and API and Dataset Streaming.