System email bounce/reject rates
Incident Report for Crunch.io
Resolved
This incident has been resolved.
Posted Nov 05, 2021 - 09:08 PDT
Monitoring
Users must use a system-generated one-time token sent by email to set or reset their password to use Crunch. Following an internal change to how Crunch systems process outbound emails to users, we are closely monitoring a possible increase in the rejection rate reported to us by recipients’ mail services (SMTP).
If you believe you or your clients have failed to receive a password-reset message sent by Crunch, support@crunch.io may be able to provide a password-setting token for you. Please retry ‘reset password’ in the app before requesting a manual token.
Posted Oct 18, 2021 - 13:07 PDT