Performance issue with dataset loading and task processing

Incident Report for Crunch.io

Resolved

This incident has been resolved.
Posted Jul 27, 2026 - 16:35 PDT

Monitoring

A fix has been implemented and we are monitoring the system
Posted Jul 27, 2026 - 13:18 PDT

Update

We are continuing to investigate this issue.
Posted Jul 27, 2026 - 11:28 PDT

Investigating

Crunch is investigating reports that datasets are not loading for some users and data processing is degraded
Posted Jul 27, 2026 - 11:28 PDT
This incident affected: Crunch.io Web Application and API, Dataset Streaming, and Individual Dataset Access.